News

Feb 2nd Removal of unsupported PHP versions.

We have removed unsupported versions of PHP scripting language to increase the performance and security of our servers. Currently we support PHP versions 7.4, 8.0, and 8.1 (8.0 and 8.1 were just installed). If your website is having any issues with displaying content or error messages, then we recommend that you contact your webdesigner or check ... Read More »

Oct 1st [RESOLVED] Issue with invalid security certificate.

In the past day, you may have noticed error messages with your email program on your computer or cellphone checking for email saying "security certificate is invalid" or "target principal name is incorrect". This was a known cPanel issue and they released a script to fix the issue. We have run the script and the issue should now be resolved.

Powered by WHMCompleteSolution